Erfahrungsbericht: Neulich habe ich die Pflege einer Joomla 1.0.15-Seite übernommen. Also erst mal Dateien per FTP vom Server geholt und auf mein lokales xampp aufgespielt, Datenbank importiert, Pfade angepasst und die Seite aufgerufen. Die Seite ist zwar da, aber dort, wo der Inhalt angezeigt werden soll, steht folgende Fehlermeldung:

Warning: Parameter 2 to frontpage() expected to be a reference, value given in C:\xampp\htdocs\xy\includes\Cache\Lite\Function.php on line 100

Des Rätsels Lösung (nach vielen Stunden Verzweiflung): Joomla 1.0. und PHP in der Version 5.3 verstehen sich nicht so gut. Und die aktuelle Version von xampp arbeitet nun mal mit PHP 5.3.

Doch wo schaut man nach, welche PHP-Version auf dem Server läuft?

Joomla 1.0: System – System-Info

Screenshot

Joomla 1.5: Hilfe – System-Info

Screenshot

Bei vielen Providern kann man die PHP-Version übrigens selbst einstellen.

Beim Googlen habe ich außerdem festgestellt, dass auch etliche Life-Sites diesen Fehler aufweisen. Also: Kontrolliert Eure Seiten regelmäßig!